Office 自定义工具：帮助文件

Office 自定义工具帮助文件

此帮助文件中的信息针对 Office 自定义工具 (OCT)，也可在 Office 2013 资源工具包的"Office 2013 中的 Office 自定义工具"中联机找到该信息。

若要从 OCT 中访问帮助，请单击"帮助"图标或单击对话框中的"帮助"按钮。

Office 自定义工具帮助目录

Office 自定义工具：概述 |
安装程序 |
Office 自定义工具：安装位置和单位名称 |
Office 自定义工具：其他网络资源 | Office 自定义工具："添加/修改网络服务器项"对话框
Office 自定义工具：授权和用户界面 |
Office 自定义工具：删除之前的安装 |
Office 自定义工具：添加安装并运行程序 | Office 自定义工具："添加/修改程序项"对话框
Office 自定义工具：Office 安全设置 |
Office 自定义工具：修改安装程序属性 | Office 自定义工具："添加/修改属性值"对话框
功能 |
Office 自定义工具：修改用户设置 |
Office 自定义工具：设置功能安装状态 |
文件和注册表项 |
Office 自定义工具：添加文件 | Office 自定义工具："文件目标路径"对话框
Office 自定义工具：删除文件 | Office 自定义工具："文件路径"对话框
Office 自定义工具：添加注册表项 | Office 自定义工具："添加/修改注册表"对话框
Office 自定义工具：删除注册表项 | Office 自定义工具："删除/修改注册表项"对话框
Office 自定义工具：配置快捷方式 | Office 自定义工具："添加/修改快捷方式项"对话框
Outlook |
Office 自定义工具：Outlook 配置文件 |
Office 自定义工具：添加帐户 | Office 自定义工具："添加帐户和帐户设置"对话框 Office 自定义工具：Exchange 设置 Office 自定义工具：缓存模式
Office 自定义工具：导出设置 |
Office 自定义工具：指定发送/接收组 | Office 自定义工具："新建 Exchange 组"对话框 Office 自定义工具："修改组"对话框 Office 自定义工具："重命名 Exchange 组"对话框 Office 自定义工具："修改通讯簿设置"对话框


Office 自定义工具：设置功能安装状态

设置功能安装状态

自定义 Office 功能在用户计算机上的安装方式。

若要更改某功能的安装状态，请单击它，然后选择安装状态。有些功能称为父功能，包含多个子功能。若要查看子功能，请单击父功能左侧的加号 (+) 将其展开。

更改功能的安装状态时，该功能的名称及其所有子功能（如果有）的名称都会以粗体显示，指示安装程序会对安装应用这些更改。未以粗体显示的功能会使用默认安装状态安装。如果要删除所做的某项更改，请选择该功能，然后选择"重置"或"重置分支"。

安装过程中，用户通常可以使用以下功能安装状态。并非所有安装状态都可用于每个功能。例如，如果某功能包含无法播发的组件，则该功能的可用安装状态列表中不包含"首次使用时安装"。

从本机运行 | 安装程序复制文件，并将与该功能关联的注册表项和快捷方式写入用户的硬盘，应用程序或功能在本地运行。
从本机运行全部程序 | 与"从本机运行"一样，但属于该功能的所有子功能也设置为此状态。
首次使用时安装 | 安装程序将该功能及其所有子功能的组件留在本地安装源中，直到用户首次尝试使用该功能时才安装这些组件。这也称为播发功能。应用程序名称旁边的菜单图标上会添加符号 [1]。
不可用 | 不在计算机上安装该功能及属于该功能的所有子功能的组件。应用程序名称旁边的菜单图标上会添加一个红色的 [X]。

每个功能还可使用以下选项。

隐藏 | 如果安装程序以交互方式运行，则在安装期间，安装程序将不在功能树中显示该功能。当安装程序在 Office 安装后以维护模式运行时，不会隐藏该功能。该功能名称的前面会放置符号 [H]，以指示该功能处于隐藏状态。
锁定 | 在 Office 安装期间或安装后的维护模式中，用户无法更改为该功能选择的安装状态。该功能名称的前面会放置符号 [L]，以指示该功能处于锁定状态。
重置 | 该功能返回到其默认安装状态。这与选择该功能并单击"重置分支"按钮的作用相同。

如果您明确将某功能设置为其默认状态，该功能名称的前面会放置符号 [F]，以指示将强制该功能进入此状态。如果您要创建安装程序自定义文件以修改现有 Office 安装，则此选项会很有用。如果您不更改功能的安装状态，则安装程序不会在用户计算机上更改该功能。如果您指定一项更改，甚至将该功能设置为其正常默认状态，则安装程序会确保在用户计算机上将该功能设置为该状态。

更改某功能的安装状态时，安装程序可能会更改父功能或子功能的安装状态以符合更改后的状态。例如，如果将父功能设置为"首次使用时安装"，但将子功能设置为"从本机运行"，则安装程序会将父功能的状态也更改为"从本机运行"。

用户以交互方式运行安装程序时，安装程序不在功能树中显示隐藏功能，但该功能会按照其定义的安装状态进行安装。属于该隐藏功能的所有子功能也处于隐藏状态。

注意：

"隐藏"设置的最佳用途是简化用户的功能树。例如，您可以隐藏功能树的"Office 工具"分支，以便用户不必决定他们需要的工具；只安装您选择的工具。

如果您将某功能设置为"不可用"并在功能树中隐藏它，则用户仍可以通过安装父功能或在维护模式中运行安装程序，来更改设置和安装该功能。例如，如果您将"人名智能标记加载项"功能设置为"不可用"和"隐藏"，则用户仍可通过将父"智能标记加载项"功能设置为"从本机运行全部程序"来安装它。如果您需要帮助阻止用户安装隐藏功能，请选择"不可用"、"隐藏"和"锁定"安装状态。在这种情况下，该功能或应用程序将不会安装，并且在维护模式下也不可用。用户不能通过更改父功能的状态来安装它。在安装 Office 后，反转"不可用"、"隐藏"和"锁定"安装状态的唯一方法是，使用 OCT 创建配置为更改该功能安装状态的安装程序自定义文件，然后将该自定义文件应用于用户的计算机。

有关详细信息，请参阅 Office 2013 资源工具包中的"Office 2013 中的 Office 自定义工具"。


Office 自定义工具：添加安装并运行程序

添加安装并运行程序

在 Office 安装完成之前或之后运行其他可执行程序。

安装程序按列出的顺序运行所有命令行，只有在执行所有命令行之后，才会完成安装。

注意：

不要添加需要重新启动计算机的程序，除非该程序是列表中的最后一个程序。如果自定义程序重新启动计算机，则会完成 Office 安装。此列表接下来的任何自定义程序都不会运行。

若要将程序添加到列表，请单击"添加"。若要修改程序，请选择它，然后单击"修改"。若要删除程序，请选择它，然后单击"删除"。若要更改列表的顺序，请选择一个程序，然后单击"移动"箭头将该程序在列表中向上或向下移动。


Office 自定义工具："添加/修改网络服务器项"对话框

"添加/修改网络服务器项"对话框

单击"其他网络资源"对话框中的"添加"时，会打开"添加网络服务器项"对话框。如果在"其他网络资源"对话框中选择一项，然后单击"修改"，则会打开"修改网络服务器项"对话框。

  1. 在"添加网络服务器项"或"修改网络服务器项"对话框中的"网络服务器"框中，键入服务器的路径和名称。可以使用 UNC 路径，如果所有用户都可使用同一驱动器号访问服务器，则可在路径中使用驱动器号。如果为所有用户定义了环境变量，则可在该路径中包含由百分号 (%) 分隔的环境变量。

    例如：

    z:\office

    \\server1\share\office_root

    %USERNAME%\office_root

    还可以单击"浏览"在网络上搜索服务器。

  2. 单击"确定"。


Office 自定义工具：OpenDocument 演示文稿 (.odp) 格式和 PowerPoint (.pptx) 格式之间的区别

OpenDocument 演示文稿 (.odp) 格式和 PowerPoint (.pptx) 格式之间的区别

以 OpenDocument 演示文稿 (.odp) 格式从 PowerPoint 2013 中保存文件，然后在 PowerPoint 2013 中重新将其打开时，您可能会注意到 PowerPoint 版本和 OpenDocument 版本之间的一些格式差异。同样，在 PowerPoint 中打开 OpenDocument 文件时，您可能也会看到格式差异。这是因为这两种文件格式支持的功能是不同的。

注意：

使用这两种文件格式时您会遇到的差异通常限制为格式差异和功能可用性。数据和内容将转换，但在这两种格式之间，您对数据和内容进行格式设置并与之交互的方式可能会有所不同。

如果要在 ODF 或 OpenXML（或其他格式）之间切换默认文件格式，请执行以下操作：

  1. 单击"文件"选项卡。

  2. 在"帮助"下，单击"选项"。

  3. 单击"保存"，然后在"保存演示文稿"下的"将文件保存为此格式"列表中，单击要在默认情况下使用的文件格式。

我以 OpenDocument 演示文稿的格式保存 PowerPoint 演示文稿时，会发生什么情况？

下表显示 OpenDocument 演示文稿 (.odp) 格式完全支持、部分支持或不支持的 PowerPoint 2013 功能：

  • 支持 PowerPoint 2013 和 OpenDocument 演示文稿格式都支持此功能。不会丢失内容、格式设置和可用性。

  • 部分支持 PowerPoint 2013 和 OpenDocument 演示文稿格式都支持此功能，但格式设置和可用性可能会受到影响。不会丢失文本或数据，但格式设置及使用文本或图形的方式可能会有所不同。

  • 不支持 PowerPoint 2013 中的功能在 OpenDocument 演示文稿格式中不受支持。如果您计划以 OpenDocument 演示文稿格式保存 PowerPoint 2013

    文档，请不要使用此功能，否则您可能会丢失该部分文档的内容、格式设置和可用性。

有关 OpenDocument 格式中完全、部分或不支持的 Office 2013 图形功能的信息，请参阅本文末尾的"图形元素"表。

区域 子区域 支持级别 注释

动画

进入/退出动画

部分支持

ODF 无法支持的任何进入或退出动画会更改为显示或消失动画。

动画

颜色动画

不支持

不支持涉及颜色变化的动画。

动画

缩放动画

不支持

不支持爆炸、闪光灯、增大和缩小、垂直高度动画。

动画

动画延迟

完全支持

动画

动画计时

完全支持

动画

文本动画

完全支持

动画

触发的动画

完全支持

动画

动画声音

不支持

动画

媒体动画

完全支持

动画

SmartArt

不支持

动画

图表部分

部分支持

图表部分上的动画会转换为整个图表上的动画。

动画

OLE 动作动画

不支持

动画

母版/布局动画

不支持

过渡

过渡

部分支持

支持可在 SMIL 规范或开放文档格式规范中找到的所有过渡，但具有以下例外：不支持百叶窗、切、停车带、梳理和新闻快报过渡。

过渡

切换声音

不支持

内容

媒体（电影/声音）

完全支持

内容

嵌入 WAV 文件

完全支持

内容

OLE

完全支持

内容

ActiveX 控件

不支持

内容

表

部分支持

将其中包含表的演示文稿保存为 .odp 格式时，这些表会变为图像，无法编辑。

内容

页眉/页脚

部分支持

将其中包含页眉或页脚的文件保存为 .odp 格式时，页眉和页脚会变为文本框。

内容

日期字段

部分支持

包含所有日期类型，但它们可能会由其他 ODF 应用程序转换为默认类型。

内容

隐藏形状

完全支持

内容

隐藏幻灯片

完全支持

宏/可编程性

宏/OM/可编程性

不支持

演示文稿设置

页面大小

部分支持

尽管页面大小随演示文稿保存，但"页面设置"对话框中的"页面大小"设置是不准确的。该对话框会尝试默认设置为默认页面大小。

演示文稿设置

自定义显示

完全支持

演示文稿设置

旁白/计时

完全支持

演示文稿设置

显示设置

部分支持

演示文稿设置

打印设置

不支持

演示文稿设置

视图设置

不支持

协作

注释

不支持

图表

图表

部分支持

有关支持的图表功能的详细信息，请参阅 Office 自定义工具：OpenDocument 电子表格 (.ods) 格式和 Excel (.xlsx) 格式之间的区别。

演示文稿设计

母版

部分支持

以 .odp 格式保存演示文稿时，会丢失所有主题信息并放到母版/布局上。不再继承主题默认值（如新形状上的字体、颜色和效果）的继承。

在以 .odp 格式保存演示文稿后打开该演示文稿时，会使用默认主题，但不应导致演示文稿中的任何更改。但是，它确实会导致在完成所有未来编辑时，好像应用了默认主题。

演示文稿设计

布局

部分支持

在其他 ODF 应用程序中打开时，会将布局视为与母版类似。

演示文稿设计

占位符

部分支持

主题信息会从占位符中丢失。

演示文稿设计

备注

完全支持

演示文稿设计

备注母版

完全支持

演示文稿设计

讲义母版

完全支持

加密

加密

不支持

保护

保护

不支持

文本

国际化文本格式设置

部分支持

不支持的功能包括：

  • 首尾字符

  • 竖排文字旋转（270，堆叠）

  • Kumimoji

  • 一些国际化编号系统映射为项目符号编号或西方编号

  • 分布式对齐

文本

对齐

部分支持

  • 不支持分布式对齐

  • 在对齐、定位或换行其他 ODF 应用程序中的文本时，可能会看到一些视觉差异。

文本

列

不支持

文本

文本旋转

部分支持

不支持 270 度旋转和堆叠文本。

文本

超链接

部分支持

支持常规超链接，但不支持悬停超链接。

文本

列表

完全支持

其他 ODF 应用程序可更改编号/项目符号或不同时支持。

文本

基本格式设置

完全支持

  • ODF 应用程序支持斜体、粗体、下划线和删除线。

  • 支持不同的字体或大小。

文本

高级格式设置/图形效果

部分支持

不支持的功能包括：

  • 图片填充、渐变填充、模式填充或空白填充文本。

  • 文本上的一些外部阴影效果。

  • 具有图片、渐变、模式或空白填充轮廓的文本。

  • 文本不能具有与填充颜色不同的轮廓。

文本

自动调整

不支持

以 .odp 格式保存演示文稿时，打开了自动调整的文本框的字体大小会设置为一个大小，在 PowerPoint 2013 中再次打开该文件时，不再自动调整。

文本

溢出

完全支持

在不同的 ODF 应用程序中，看到的溢出可能会有所不同。

图形功能

下表显示 OpenDocument 格式 (.odp) 中完全支持、部分支持或不支持哪些 PowerPoint 2013 图形功能。

  • 支持 PowerPoint 2013 格式和 OpenDocument 格式支持此功能。使用此功能的图形通常在任一格式下具有相同的外观和行为。

  • 部分支持 PowerPoint 2013 格式和 OpenDocument 格式支持此功能，但两种格式的图形的外观可能会有所不同。通常不会丢失这两种格式之间的数据，但格式设置和您处理这些图形的方式可能会有所不同。

  • 不支持 由于 PowerPoint 2013 格式和 OpenDocument 格式之间的功能和实现的独特差异，此功能在 OpenDocument 格式下不受支持。如果您计划以 OpenDocument 格式保存文档，请不要在 PowerPoint 2013 中使用这些功能。

基本形状 | 支持级别 | 注释
形状 | 支持 |
文本框 | 支持 | 支持，但文本框内的对象除外。打开 OpenDocument 文件时，会删除文本框内的对象。
艺术字 | 部分支持 | ODF 不支持 PowerPoint 2013 中的艺术字选项。因此，在保存时，艺术字会转换为文本框。会保留文本和基本文本颜色，但会丢失艺术字效果和格式设置。
3D 形状选项 | 不支持 |
图片 | 支持 | 支持，但 ODF 不支持的插入和链接选项除外。
SmartArt 图 | 支持 | 转换为一组形状
ActiveX | 不支持 |
图表中的对象 | 支持 | 转换为包含图表和对象的组。
墨迹注释 | 支持 | 墨迹注释将转换为增强型图元文件 (EMF) 图像。
对象分组 | 支持 |
对象可见性 | 支持 |
对象边框 | 支持 | 并非支持所有边框样式。不支持的边框样式会保存为默认边框样式（黑色，实线）。
对象填充 | 支持 | 支持，但幻灯片背景填充除外。 此外，具有两个以上停止点的渐变填充会丢失前两个停止点之后的所有停止点。
行格式设置 | 支持 | ODF 并不支持所有行和行尾样式。不支持的样式会分别保存为默认的黑色实线和开放型箭头。
图片裁剪 | 支持 | 支持对图片进行普通裁剪。但是，不支持裁剪具有形状的图片。
图片重新着色 | 部分支持 | 某种图片重新着色（如黑白图片）在 ODF 中具有同等效果。其他图片重新着色的效果不同，会失去光泽。图片显示相同，但无法再更改或移除重新着色。
3D 图片选项 | 不支持 |
图片样式 | 部分支持 | 部分支持边框，但外观可能会有所不同。
主题 | 不支持 |
形状上的超链接 | 不支持 |


Office 自定义工具：删除注册表项

删除注册表项

在安装 Office 时从用户的计算机中删除注册表项。

若要创建要从用户计算机中删除的注册表项的列表，请单击"添加"。若要更改列表中的项，请选择该项，然后单击"修改"。若要从列表中删除项，请选择该项，然后单击"删除"。

注意：

如果用户删除、修复或重新安装 Office，则自定义注册表项会随 Office 一起删除或重新安装。


Office 自定义工具："文件路径"对话框

"文件路径"对话框

在"文件路径"对话框中，键入要添加到文件列表以便从用户计算机中删除的文件的路径和文件名，然后单击"确定"。

该路径必须以驱动器号、UNC 路径或以下某个特殊文件夹开头：

[INSTALLLOCATION] | 安装 Office 的文件夹
[ROOTDRIVE] | 可用空间最多的本地磁盘驱动器
[ProgramFilesFolder] | Program Files 文件夹
[CommonFilesFolder] | Program Files\Common Files 文件夹
[WindowsFolder] | Windows 文件夹
[SystemFolder] | Windows System32 文件夹
[PersonalFolder] | 用户的"我的文档"文件夹
[AppDataFolder] | 用户的 Application Data 文件夹
[NetHoodFolder] | 用户的"网上邻居"文件夹


Office 自定义工具：指定发送/接收组

指定发送/接收组

为 Exchange 帐户和文件夹定义"发送/接收"组，并指定在 Outlook 2013 中的发送/接收期间对每个组执行的任务。"发送/接收"组包含一组 Outlook 2013 帐户和文件夹。可以为"发送/接收"组在 Outlook 2013 联机和脱机时指定不同的选项。

  • 不要配置发送/接收设置 - 不要为"发送/接收"组配置设置。配置 Outlook 2013 时只包含"所有帐户"组及其默认设置。（如果用户已创建其他组，则当用户升级到 Outlook 2013 时，这些组会迁移。）

  • 配置发送/接收设置 - 为"发送/接收"组配置设置（仅限 Exchange 帐户和文件夹）。

    • 单击"新建"创建一组新帐户和文件夹。

    • 单击"修改"为"发送/接收"组指定或重新定义选项。

    • 单击"重命名"更改现有"发送/接收"组的名称。

    • 单击"删除"以删除现有"发送/接收"组。

选定组的发送/接收设置

指定在列表中选定的"发送/接收"组的设置。（选定组的名称显示在选项标签中。）可以为 Outlook 2013 联机或脱机时指定不同的设置。

当 Outlook 2013 联机时：

  • 在"发送/接收"中包含该组 - 当用户单击"发送/接收"时，对该组执行发送/接收操作。

  • 安排自动发送/接收的时间间隔为 n 分钟 - 键入希望自动发送/接收操作之间间隔的分钟数。

  • 退出时执行自动发送/接收 - 当用户退出 Outlook 2013 时自动对该组执行发送/接收操作。

当 Outlook 2013 脱机时：

  • 在"发送/接收"中包含该组 - 当用户单击"发送/接收"时，对该组执行发送/接收操作。

  • 安排自动发送/接收的时间间隔为 n 分钟 - 选择各个发送/接收操作之间的间隔。

Exchange 通讯簿

  • 下载脱机通讯簿 - 当用户单击"发送/接收"时，下载脱机通讯簿。

  • 单击"通讯簿设置"打开"修改通讯簿设置"对话框。可以选择"下载上次发送/接收之后所做的更改"以便仅下载自上次下载后对通讯簿所做的更新，并且可选择是下载"完整详细信息"还是"无详细信息"。


Office 自定义工具：Office 安全设置

Office 安全设置

自定义 Office 应用程序的安全设置。

注意：

安装程序自定义 (.msp) 文件中指定的安全设置成为用户计算机上的默认设置；但是用户可在安装后更改这些设置。若要帮助锁定和强制执行安全设置，您必须使用组策略。有关安全性的详细信息，请参阅 Office 2013 资源工具包。

"受信任的发布者"列表标识经过数字签名的宏、加载项、Microsoft ActiveX 控件和 Office 应用程序使用的其他可执行代码的受信任源。单击"将下列数字证书添加到'受信任的发布者'列表中"框旁边的"添加"，将数字证书（CER 文件）添加到"受信任的发布者"列表中。

Office 应用程序与 Microsoft Internet Explorer 共享基于证书的受信任资源列表。有关详细信息，请参阅 Office 2013 资源工具包中的"规划 Office 2013 的受信任的发布者设置"。"受信任的位置"列表标识不经信任中心安全功能检查即可打开其中的任何文件的位置。

若要添加新位置，请单击"将下列路径添加到"受信任位置"列表中"旁边的"添加"，键入以下信息，然后单击"确定"：

  1. 展开"应用程序"菜单，然后选择使用此位置的 Office 应用程序。

  2. 在"路径"框中，键入受信任位置的路径。输入带驱动器号的完全限定路径或 UNC 路径。该路径可包含环境变量。

  3. 选择"同时信任此位置的子文件夹"将子文件夹也成为受信任位置。

  4. 在"说明"框中，键入描述该位置的用途的文本。

若要从此列表中删除受信任位置，请选择位置，然后单击"删除"。

注意：

在此处指定一个或多个受信任位置时，以前在用户计算机上定义的"受信任位置"列表会被清除并由此列表取代。

选择"删除 OCT 在安装过程中写入的所有受信任位置"以清除用户计算机上的"受信任位置"列表。如果需要清除用户计算机上的"受信任位置"列表，即使此对话框中未定义受信任位置，也可以选中此复选框。

在"默认安全设置"列表中，为加载项、模板和 Office 应用程序设置默认安全级别。对于每个 Office 应用程序，可设置下面一些选项：

  • 允许的受信任位置选项

    • 允许不在用户计算机上的受信任位置

    • 仅允许用户计算机上的受信任位置(应用程序默认)

    • 禁用所有受信任位置，仅信任由受信任的发布者签署的文件

  • 应用程序加载项警告选项

    • 禁用所有应用程序扩展

    • 要求由受信任发布者签署应用程序扩展

    • 要求签署扩展；并以无提示方式禁用未签署的扩展

    • 启用所有已安装的应用程序加载项(应用程序默认)

  • VBA 宏警告选项

    • 禁用所有 VBA 宏

    • 禁用针对未签署的 VBA 宏的信任栏警告(未签署的代码将被禁用)

    • 禁用所有 VBA 宏，并发出通知(应用程序默认)

    • 不执行 VBA 宏安全检查(不推荐；所有文档中的代码均可运行)

  • Microsoft Office Project - 加载项和模板

    • 信任所有安装的加载项和模板

    • 不信任安装的加载项和模板

  • Microsoft Office Project - 安全级别

    • 很高 - 仅允许运行安装在受信任位置的宏。其他所有已签署或未签署的宏都将被禁用。

    • 高 - 仅允许运行来自受信任来源的签署的宏；未签署的宏将被禁用。

    • 中 - 用户可以选择是否运行存在安全隐患的宏。

    • 低(不推荐) - 不保护用户，用户可能遭受不安全的宏的危害。

不安全的 ActiveX 初始化 - 确定未签署（因此可能不安全）的 ActiveX 控件是否可使用持续数据（即从控件的一个实例保存到另一个实例的数据）进行初始化。可能的值包括：

  • <不配置> - 安装程序不修改在用户计算机上指定的设置。使用默认设置（即"提示用户使用持续的数据"）安装新应用程序。

  • 提示用户使用控件默认值 - 在应用程序启动可能不安全的 ActiveX 控件之前警告用户。如果用户信任文档的来源，则会使用其默认设置初始化该控件。

  • 提示用户使用持续的数据 - 在应用程序启动可能不安全的 ActiveX 控件之前警告用户。如果用户信任文档的来源，则会使用持续的数据初始化该控件。

  • 不提示 - 运行所有未签署的 ActiveX 控件，而不提示用户。此设置提供的保护最少，不建议使用。

  • 不提示并禁用所有控件 - 不运行所有未签署的 ActiveX 控件，并且不提示用户。


Office Customization Tool overview

You use the Office Customization Tool (OCT) to customize an installation of the Microsoft Office 2010. When you run OCT, you choose whether to create a new Setup customization file or open an existing one. If you are creating a new file, OCT displays a list of the products available on the network installation point. You must select a single product that you want to customize. To start OCT, type setup.exe /admin on the command line.

注意：

The Office 2010 OCT requires version 4.0 or later of Windows Installer on all computers running Office, including the computer you use to run OCT.

Setup customization files

By using OCT, you customize Office and save your customizations in a Setup customization file (.msp file), and then place the file in the Updates folder on the network installation point. When you install Office, Setup looks for a Setup customization file in the Updates folder and, if found, applies those customizations. If you put the customization file somewhere other than the Updates folder, you can use the Setup command-line option /adminfile to specify the fully qualified path to the file; for example, setup.exe /adminfile \\server_name\share_name\subfolder\custom.msp.

For information about Setup command-line options, see Setup command-line options for Office 2010 in the Microsoft Office 2010 Resource Kit.

注意：

If you use a folder other than the Updates folder for your customization files, you can specify its location in the Config.xml file by using the SUpdateLocation attribute of the SetupUpdates element. For more information, see Config.xml file in Office 2010 in the Microsoft Office 2010 Resource Kit.

You also can use a Setup customization file to change an existing installation. Because a Setup customization file is an expanded form of a Windows Installer .msp file, you apply the customization file to the user's computer just as you would a software update, and the user's existing Office installation is updated with your customizations. For example, if you change the installation states of some features to Not Available and then apply the resulting customization file to an existing installation of Office, those features are removed from the user's computer.

If you use the OCT to modify an existing .msp customization file, we recommend that you select the .msp file for the same product you are customizing. For example, if you are customizing an existing Microsoft Office Professional Plus 2010 installation, select an Office Professional Plus 2010 customization .msp file.

OCT provides support for importing Setup customization updates as follows:

  • 32-bit Setup customization updates can be imported into 64-bit OCT and can then be used to customize 64-bit Office products.

  • 64-bit Setup customization updates can be imported to 32-bit OCT and can then be used to customize 32-bit Office products.

  • A 32-bit Setup customization update that is imported to 64-bit OCT is converted to 64-bit, and a 64-bit customization update that is imported to 32-bit OCT is converted to 32-bit. To import a customization update (.msp file), in the Office Customization Tool, select Import on the File menu. In the Open dialog box, select the .msp file that you want to convert, and then click Open to start the conversion.

注意：

Importing customization .msp files is intended for equivalent cross-architecture products only. You can import a 32-bit Microsoft Office Professional Plus 2010 customization .msp file into the 64-bit version of the OCT for a 64-bit Office Professional Plus 2010 .msp file. However, you cannot import a 32-bit Microsoft Word 2010 stand-alone customization .msp file into the 64-bit OCT for a 64-bit Office Professional Plus 2010 .msp file; doing so is prevented and displays an error message. For information about how to use the OCT to create a Setup customization file and about all the areas that you can configure with the OCT, see Office Customization Tool in Office 2010 in the Microsoft Office 2010 Resource Kit.

You cannot import 2007 Office system Setup customization updates into Office 2010 OCT.

The Import feature can also be used in cases where you have created an initial Setup customization .msp file for an Office 2010 product (for example, Microsoft Office Professional Plus 2010) and later you want to modify the installation to add language packs for that product. In such cases, you first add the language packs to the network installation point that contains the Office product source files. Then you run the OCT from the root of the network installation point, create a new Setup customization file for the same product, and import the original customization .msp file that you created previously for the product (Office Professional Plus 2010 in this example). To import the .msp file, in the OCT, on the File menu, click Import. In the Open dialog box, select the previously created customization .msp file that you want to update. On the File menu, click Save As. Specify a unique name for the .msp file, and click Save. Importing the previously created customization .msp file into the OCT will update the .msp file and include the added languages.For more information about how to import an .msp customization file, see Import an Office 2010 Setup customization file in the Microsoft Office 2010 Resource Kit. For information about how to create a network installation point, see Create a network installation point for Office 2010 in the Microsoft Office 2010 Resource Kit.

There are some options in OCT that are applicable only on a new installation of Office. These options are identified in OCT and in the OCT Help file. For example, you can use the INSTALLLOCATION element to specify the folder where Office is installed on the user's computer. If a customization file is applied to an existing installation, however, the INSTALLLOCATION element is ignored. (You need to uninstall and reinstall Office to change the installation location.)

Select Save on the File menu to save the Setup customization file before you exit OCT.

Configuring OCT

OCT consists of following four major sections, each of which is divided into a number of pages containing the following customizable options:

  • Setup

    • Installation location and organization name

    • Additional network sources

    • Licensing and user interface

    • Remove previous installations

    • Add installations and run programs

    • Office security settings

    • Modify Setup properties

  • Features

    • Modify user settings

    • Set feature installation states

  • Additional content

    • Add files

    • Remove files

    • Add registry entries

    • Remove registry entries

    • Configure shortcuts

  • Outlook

    • Outlook profile

    • Add accounts

    • Export settings

    • Specify Send/Receive groups


Office 自定义工具："添加/修改程序项"对话框

"添加/修改程序项"对话框

在"添加安装并运行程序"对话框中，如果单击"添加"，将打开"添加程序项"对话框。如果在"添加安装并运行程序"对话框中选择项，然后单击"修改"，将打开"修改程序项"对话框。可以在"添加程序项"或"修改程序项"对话框中输入以下信息：

  1. 在"目标"框中，键入可执行程序的路径和文件名。

    展开"目标"列表以便在可执行文件的路径中加入以下任何标准 Windows 文件夹。

    [INSTALLLOCATION]

    安装 Office 的文件夹

    [WindowsFolder]

    Windows 文件夹

    [System Folder]

    Windows System32 文件夹

    [ProgramFilesFolder]

    Program Files 文件夹

    [CommonFilesFolder]

    Program Files\Common Files 文件夹

    [DesktopFolder]

    Windows 桌面文件夹

    [StartMenuFolder]

    Windows"开始"菜单

    [ProgramMenuFolder]

    Windows"开始"\"程序"菜单

  2. 在"参数"框中，键入命令行选项字符串；例如，/q /path c:\temp。

  3. 如果要在 Office 安装完成后运行"目标"框中列出的程序，请选择"安装 Office 产品后运行此程"。这是推荐的选项。如果程序非正常终止，或者它重新启动计算机，Office 安装将不受影响。但是，将不会运行列表中接下来的程序。

  4. 如果要在 Office 安装开始之前运行"目标"框中列出的程序，请选择"安装 Office 产品前运行此程序"。如果程序非正常终止，或者它重新启动计算机，将不安装 Office 并且不会运行列表中接下来的程序。

  5. 单击"确定"。


Office 自定义工具："新建 Exchange 组"对话框

"新建 Exchange 组"对话框

在"新组名"框中，键入您要创建的 Exchange 发送/接收组的名称，然后单击"确定"。


Office 自定义工具：安装位置和单位名称

安装位置和单位名称

为安装中包括此安装程序自定义文件的所有用户指定默认安装文件位置和单位名称。

在"默认安装路径"框中，键入用户计算机上安装程序将在其中安装 Office 的文件夹的路径。您可以保留默认路径 [ProgramFilesFolder]。使用默认路径时，Office 将安装到 ([ProgramFilesFolder]\Microsoft Office)。

只有首次在用户计算机上安装 Office 时，才会识别此选项；如果不卸载和重新安装 Office，则无法更改安装路径。

单击"单位名称"以指定在"关于"框、"帮助"菜单和 Office 应用程序的横幅页上显示的名称。您指定的名称将用作其安装使用此自定义文件的所有用户的默认公司名称。


Office 自定义工具：缓存模式

缓存模式

使用以下选项可将用户的 Outlook 配置文件配置为使用 Exchange 邮箱的本地副本。

不配置缓存 Exchange 模式 - 默认情况下，可从 Exchange Server 计算机访问 Exchange 邮箱，而不是将其缓存到用户计算机上的脱机 Outlook 数据文件 (.ost) 中。

配置缓存 Exchange 模式 - 创建 .ost 文件或使用现有 .ost 文件。用户使用其 Exchange 邮箱的本地副本。

如果选择"使用缓存 Exchange 模式"，则可使用以下选项为用户配置缓存 Exchange 模式：

  • 仅下载邮件头 - 仅从用户的 Exchange 邮箱下载邮件头的副本。

  • 先下载邮件头，再下载整个项目 - 从用户的 Exchange 邮箱下载邮件头的副本，然后下载邮件的副本。

  • 下载整个项目 - 从用户的 Exchange 邮箱下载完整邮件（邮件头和邮件正文）的副本。

  • 低速连接时仅下载邮件头 - 当检测到低速网络连接时，仅从用户的 Exchange 邮箱下载邮件头的副本。

  • 下载共享的非邮件文件夹 - 从其他用户的邮箱下载共享的非邮件文件夹。

  • 下载公用文件夹收藏夹 - 下载公用文件夹收藏夹的列表。

  • 自定义 .ost 和 .oab 文件的位置

    • Outlook 数据(.ost)文件的路径和文件名 - 指定脱机 Outlook 数据文件的名称和存储位置。

    • 存储脱机通讯簿文件的目录路径 - 指定脱机通讯簿文件的存储路径。


Office 自定义工具："修改通讯簿设置"对话框

"修改通讯簿设置"对话框

配置 Outlook 使脱机通讯簿保持最新状态的默认方式。请在以下选项中选择：

  • 下载上次发送/接收之后所做的更改 -Outlook 仅下载上次发送/接收之后对通讯簿所做的更改。这通常比下载完整通讯簿所需的时间少。

  • 完整详细信息 - 在下载通讯簿时，Outlook 会复制每个条目的所有详细信息。

  • 无详细信息 - 在下载通讯簿时，Outlook 仅复制必要信息，例如每个条目的名称和电子邮件地址。这通常需要更少的下载时间，但脱机通讯簿中不包含地址详细信息。这是 Outlook 通讯簿 (OAB) 2.0 和 3.0 版支持的旧选项。如果 Outlook 连接到支持 OAB 4.0 或更高版本的服务器，则即使选中此选项，也会下载完整详细信息。


Office 自定义工具：其他网络资源

其他网络资源

指定具有网络安装点副本的其他服务器。

如果原始网络安装点不可用，并且安装程序正在按需安装某项功能或正在修复 Office，则安装程序会按指定的顺序检查此列表中的服务器。

若要将服务器添加到列表中，请单击"添加"。若要编辑列表中的项，请选择一个服务器，然后单击"修改"。若要从此列表中删除服务器，请选择该服务器，然后单击"删除"。若要更改列表的顺序，请选择一个服务器，然后单击"移动"箭头在列表中向上或向下移动该服务器。

若要从列表中删除所有服务器，请单击"清除现有服务器列表"。


Office 自定义工具：了解文件格式

了解文件格式

选择默认文档格式可能会在某种程度上影响您使用 Office 的方式以及您与其他生产力应用程序的用户交换文档的方式。最初开发文档格式的目的是反映一个或多个应用程序的功能和行为（生产力应用程序的功能和行为可能大不相同）。例如，最初开发 OpenDocument 格式 (ODF) 的目的是反映基于 OpenOffice 的生产力套件的功能和行为，而最初开发 OpenXML 的目的是反映 Office 的功能和行为。Office 现在提供对 ODF 的支持，并使 Office 用户能够以 ODF 保存其文档。但是，由于 Office 和 OpenOffice 功能不完全相同或实现方式不同，因此使用不受支持的功能（参见下文以获取这些功能的链接列表）和以 ODF 保存文档的 Office 用户可能会遇到文档的可编辑性发生更改，并且有时还会看到内容丢失的情况。

有关 ODF 1.1 中对 Office 的常用功能的支持级别的详细信息，请参阅下面的链接。它显示了 ODF 1.1 格式中完全支持、部分支持或不支持的 Office 功能。

  • 受支持 Office 中的相关应用程序和 ODF 1.1 的相关部分都支持此功能。不会丢失内容、格式设置和可用性。

  • 部分受支持 Office 中的相关应用程序和 ODF 1.1 的相关部分都支持此功能，但格式设置和可用性可能会受到影响。不会丢失文本或数据，但格式设置和您使用文本、图形及文档外观的方式可能有所不同。

  • 不受支持 Office 中的相关应用程序的功能在 ODF 1.1 的相关部分中不受支持。如果您计划以 ODF 1.1 保存文档，请不要使用此功能，否则您可能会丢失文档这一部分的内容、格式设置和可用性。

若要概括性了解有关 ODF 的详细信息，请参阅：

  • OASIS 标准组织

  • ISO 组织（该链接可能指向英文页面）

若要了解文件格式差异的详细信息，请参阅：

  • Office 自定义工具：OpenDocument 电子表格 (.ods) 格式和 Excel (.xlsx) 格式之间的区别

  • Office 自定义工具：OpenDocument 演示文稿 (.odp) 格式和 PowerPoint (.pptx) 格式之间的区别

  • Office 自定义工具：OpenDocument 文本 (.odt) 格式和 Word (.docx) 格式之间的区别


Office 自定义工具："重命名 Exchange 组"对话框

"重命名 Exchange 组"对话框

在"新组名"框中键入 Exchange 发送/接收组的新名称，然后单击"确定"。


Office 自定义工具：添加注册表项

添加注册表项

安装 Office 时，在用户计算机上添加或修改注册表项。

若要创建要添加到用户计算机的注册表项的列表，请单击"添加"。若要更改列表中的项，请选择它，然后单击"修改"。若要从列表中删除项，请选择它，然后单击"删除"。单击"导入"可添加注册表文件（REG 文件）中的一组项。如果 REG 文件中的某项与列表中的项重复，OCT 将提示您选择是否用 REG 文件中的项覆盖现有注册表项。

注意：

本节中自定义的注册表项可能覆盖在 OCT 中的其他位置自定义的设置。使用本节可自定义不能直接在 Office 用户界面中设置且使用 OCT 中的其他方法无法配置的选项。

有关详细信息，请参阅 Office 2013 资源工具包中的"Office 2013 中的 Office 自定义工具"。


Office 自定义工具：修改安装程序属性

修改安装程序属性

设置在 Office 安装期间应用的属性的值。只有首次在用户计算机上安装 Office 时，才能自定义安装程序属性值；如果将安装程序自定义文件应用于现有安装，则该文件中设置的值不会生效。

若要添加属性值，请单击"添加"。若要修改已添加的属性，请选择该属性，然后单击"修改"。若要删除已添加的属性，请选择该属性，然后单击"删除"。

有关属性及其值的详细信息，请参阅 Office 2013 资源工具包中的"Office 2013 中的安装程序属性"。


Office 自定义工具："添加帐户和帐户设置"对话框

"添加帐户和帐户设置"对话框

如果要添加新帐户，请选择要添加的帐户的类型，然后单击"下一步"。

在"<帐户类型> 设置"对话框中，设置适合要添加或修改的帐户类型的选项。单击"其他设置"可显示其他配置选项。完成后，单击"完成"。

为确保电子邮件服务不会重叠，Outlook 可能不允许您为同一类型的服务添加多个新帐户。例如，Outlook 会验证所有 POP 帐户是否具有唯一名称。下表显示 Outlook 如何确定是否可将与现有帐户具有相同类型的新帐户添加到安装程序自定义文件。

帐户类型 | 是否允许重复帐户？ | 用于确定是否存在冲突的数据
POP3 | 是 | 帐户名
IMAP | 是 | 帐户名
Exchange | 是 | 帐户名
Outlook 数据文件 (.pst) | 是 | .pst 文件的文件名和路径
Outlook 通讯簿 | 否 | 帐户是否存在
Internet 目录服务 (LDAP) | 是 | 帐户名

Exchange 帐户的设置

如果选择 Exchange 作为要创建的帐户类型，请在"Exchange 设置"对话框中键入基本信息，然后单击"其他设置"。在"Exchange"选项卡上，使用以下选项为脱机使用和 Outlook 无处不在配置用户的 Outlook 配置文件：

选项 说明

启用脱机使用

  • 在"Outlook 数据文件(.ost)的路径和文件名"框中键入脱机 Outlook 数据文件的名称和位置。

  • 在"存储脱机通讯簿文件的目录路径"框中键入脱机通讯簿文件的路径。

配置 Outlook 无处不在

  • 选择"配置 Outlook 无处不在"以启用 Outlook 无处不在，然后可配置以下选项：

    • 选择"使用 HTTP 连接到 Exchange 邮箱"，然后键入 Outlook 无处不在代理服务器的 URL。

      不要键入 http:// 或 https:// 作为名称的一部分。根据您选择的身份验证设置，在您键入名称后，相应的项（http:// 或 https://）将自动包含在框中。

    • 选择"仅使用 SSL 连接"，选择"使用 SSL 连接时相互验证会话"，然后键入代理服务器的主体名称。

    • 若要指定在检测到快速连接时，Outlook 无处不在先尝试使用 HTTP 进行连接，请选择"在快速网络中，先使用 HTTP 连接，再使用 TCP/IP 连接"。

    • 若要指定在检测到低速连接时，Outlook 无处不在先尝试使用 HTTP 进行连接，请选择"在低速网络中，先使用 HTTP 连接，再使用 TCP/IP 连接"。

    • 展开"连接到 Exchange 的代理服务器时使用此身份验证"菜单，然后选择一种身份验证方法。

通过单击"Exchange 设置"对话框上的"缓存模式"选项卡，可配置是否将用户的邮件复制到用户的本地计算机以及如何复制。

选项 说明

配置缓存 Exchange 模式

指定从 Exchange Server 计算机访问 Exchange 邮箱，而不是缓存在用户计算机上的脱机 Outlook 数据文件 (.ost) 中。

不配置缓存 Exchange 模式

指定用户使用其 Exchange 邮箱的本地副本。若要调整此配置，请选择以下项之一：

  • 选择"下载邮件头"仅从用户的 Exchange 邮箱下载邮件头的副本。

  • 选择"先下载邮件头，再下载整个项目"从用户的 Exchange 邮箱下载邮件头的副本和邮件的副本。

  • 选择"下载整个项目"从用户的 Exchange 邮箱下载完整邮件（邮件头和邮件正文）的副本。选择以下任一或所有项：

    • 选择"低速连接时仅下载邮件头"以便在检测到低速网络连接时，仅从用户的 Exchange 邮箱下载邮件头的副本。

    • 选择"下载共享的非邮件文件夹"从其他用户的邮箱下载这些文件夹。

    • 选择"下载公用文件夹收藏夹"下载公用文件夹收藏夹的列表。


Office 自定义工具：OpenDocument 电子表格 (.ods) 格式和 Excel (.xlsx) 格式之间的区别

OpenDocument 电子表格 (.ods) 格式和 Excel (.xlsx) 格式之间的区别

以 OpenDocument 电子表格 (.ods) 格式在 Excel 2013 中保存文件，然后再次在 Excel 2013 中打开该文件时，您可能会注意到 Excel 2013 版本和 OpenDocument 版本之间的一些格式设置差异。同样，当您在 Excel 2013 中打开 OpenDocument 文件时，您可能也会看到格式设置差异。这是因为这两种文件格式支持的功能是不同的。

注意：

使用这两种文件格式时您会遇到的差异通常限制为格式差异和功能可用性。数据和内容将转换，但在这两种格式之间，您对数据和内容进行格式设置并与之交互的方式可能会有所不同。

如果要在 ODF 或 OpenXML（或其他格式）之间切换默认文件格式，请执行以下操作：

  • 单击"文件"选项卡。

  • 在"帮助"下，单击"选项"。

  • 单击"保存"，然后在"保存工作簿"下的"将文件保存为此格式"列表中，单击要在默认情况下使用的文件格式。

我以 OpenDocument 电子表格格式保存 Excel 2013 演示文稿时，会发生什么情况？

下表显示 OpenDocument 电子表格 (.ods) 格式中完全支持、部分支持或不支持哪些 Excel 2013 功能：

  • 支持 Excel 2013 和 OpenDocument 电子表格格式都支持此功能。不会丢失内容、格式设置和可用性。

  • 部分支持 Excel 2013 和 OpenDocument 电子表格格式都支持此功能，但格式设置和可用性可能会受到影响。不会丢失文本或数据，但格式设置及使用文本或图形的方式可能会有所不同。

  • 不支持 Excel 2013 中的功能在 OpenDocument 电子表格格式中不受支持。如果您计划以 OpenDocument 电子表格格式保存 Excel 2013 文档，请不要使用此功能，否则可能会丢失该部分文档的内容、格式设置和可用性。

有关 OpenDocument 格式中完全支持、部分支持或不支持的 Office 2013 图形功能的信息，请参阅本文末尾的"图形元素"表。

区域 | 子区域 | 支持级别 | 注释
格式设置 | 行高/列宽 | 支持 | 外观应类似。
格式设置 | 单元格 | 支持 |
超链接 |  | 支持 | 超链接样式可能会出现问题。
格式设置 | 单元格样式 | 支持 |
打印 | 打印范围 | 支持 |
打印 | 重复行/列 | 不支持 |
打印 | 分页 | 支持 |
打印 | 页眉/页脚 | 部分支持 | 以 .ods 格式保存文件，然后在 Excel 2013 中重新打开该文件时，不支持首页或奇数页/偶数页选项。
公式 |  | 支持 |
公式 | 名称 | 部分支持 | 以 .ods 格式保存文件，然后在 Excel 2013 中重新打开该文件时，不支持本地名称、命名表达式和不连续范围的名称。
单元格注释 |  | 部分支持 | 会循环访问包含内容的注释。以 .ods 格式保存文件然后在 Excel 2013 中重新打开该文件时，可能不支持注释上的格式设置。
数据工具 | 分组和分级显示 | 支持 |
OLE 对象 |  | 支持 |
设置 | 窗口设置 | 不支持 |
设置 | 工作表/工作簿设置 | 不支持 |
保护 | 工作表保护 | 部分支持 | 以 .ods 格式保存文件，然后在 Excel 2013 中重新打开该文件时，支持不包含密码的保护。但是，无法保存或打开使用密码保护的工作表。
保护 | 信息权限管理 (IRM) | 不支持 | 无法保存 IRM 处于打开状态的文件。
保护 | 加密 | 不支持 | 无法保存具有此类型保护的文件。
数据工具 | 数据有效性 | 部分支持 | 以 .ods 格式保存文件，然后在 Excel 2013 中重新打开该文件时，无法保存某种公式类型数据有效性。
外部数据 | Web 查询 | 支持 |
外部数据 | 查询表 | 部分支持 | 一些设置（如插入列）不受支持。
表 | 总行数 | 不支持 |
表 | 表样式 | 不支持 |
数据工具 | 排序 | 部分支持 | 不支持某些高级设置。
数据工具 | 小计 | 部分支持 | 以 .ods 格式保存文件，然后在 Excel 2013 中重新打开该文件时，支持公式本身，但不支持重新应用的设置。
数据工具 | 筛选 | 部分支持 | 支持基本筛选，但不支持 Excel 2013 中添加的筛选功能。
数据透视表 | 样式 | 不支持 |
数据透视表 | 布局 | 部分支持 | 以 .ods 格式保存文件，然后在 Excel 2013 中重新打开该文件时，不支持某些布局（如压缩轴）。
数据透视表 | 计算字段 | 不支持 |
数据透视表 | 分组 | 部分支持 |
数据透视表 | OLAP 数据透视表 | 不支持 |
数据工具 | 合并汇总 | 不支持 |
共享工作簿 |  | 不支持 |
图表 | 数据标签 | 部分 | 以 .ods 格式保存文件，然后在 Excel 2013 中重新打开该文件时，不支持某些数据标签。
图表 | 数据表 | 不支持 |
图表 | 趋势线 | 部分支持 | 以 .ods 格式保存文件，然后在 Excel 2013 中重新打开该文件时，不支持某些趋势线。
图表 | 误差线 | 部分支持 | 以 .ods 格式保存文件，然后在 Excel 2013 中重新打开该文件时，不支持某些误差线。
图表 | 垂直线 | 不支持 |
图表 | 盘高-盘低线 | 不支持 |
图表 | 数据标签上的引导线 | 不支持 |
图表 | 填充雷达图 | 不支持 |
图表 | 图例 | 部分支持 | 以 .ods 格式保存文件，然后在 Excel 2013 中重新打开该文件时，不支持某些设置。
图表 | 数据透视图 | 不支持 |
图表 | 图表工作表 | 不支持 |
图表 | 复合饼图或复合条饼图 | 不支持 |
OLAP 公式 |  | 不支持 |
图表 | 图表上的形状 | 不支持 |

图形功能

下表显示 OpenDocument 格式 (.ods) 中完全支持、部分支持或不支持哪些 Excel 2013 图形功能：

  • 支持 Excel 2013 格式和 OpenDocument 格式都支持此功能。使用此功能的图形通常在任一格式下具有相同的外观和行为。

  • 部分支持 Excel 2013 格式和 OpenDocument 格式都支持此功能，但这两种格式的图形的外观可能会有所不同。通常不会丢失这两种格式之间的数据，但格式设置和您处理这些图形的方式可能会有所不同。

  • 不支持 由于 Excel 2013 格式和 OpenDocument 格式之间的功能和实现的独特差异，此功能在 OpenDocument 格式下不受支持。如果您计划以 OpenDocument 格式保存文档，请不要在 Excel 2013 中使用这些功能。

基本形状 | 支持级别 | 注释
形状 | 支持 |
文本框 | 支持 | 支持，但文本框内的对象除外。打开 OpenDocument 文件时，会删除文本框内的对象。
艺术字 | 部分支持 | ODF 不支持 Excel 2013 中的艺术字选项。因此，会在保存时将艺术字转换为文本框。将保留文本和基本文本颜色，但会丢失艺术字效果和格式设置。
3D 形状选项 | 不支持 |
图片 | 支持 | 支持，但 ODF 中不支持的插入和链接选项除外。
SmartArt 图 | 支持 | 转换为一组形状。
ActiveX 控件 | 不支持 |
Excel 2013 表单控件 | 不支持 |
图表中的对象 | 支持 | 转换为包含图表和对象的一个组。
签名行对象 | 不支持 |
相机工具/粘贴为图片链接对象 | 不支持 |
墨迹注释 | 支持 | 墨迹注释将转换为增强型图元文件 (EMF) 图像。
对象分组 | 支持 | 一些对象无法在 Excel 2013 中分组在一起，因此在打开 OpenDocument 文件时，会取消分组这些对象。这些对象包括使用 OLE 对象分组的图表、图片、形状或文本框。
对象可见性 | 不支持 | 将文件保存为 .ods，然后在 Excel 2013 中重新打开时，不可见对象会变为可见。
对象边框 | 支持 | 并非支持所有边框样式。不支持的边框样式会保存为默认边框样式（黑色，实线）。
对象填充 | 支持 | 支持，具有两个以上停止点的渐变填充会丢失前两个停止点之后的所有停止点。
行格式设置 | 支持 | ODF 并不支持所有行和行尾样式。不支持的样式会分别保存为默认的黑色实线和开放型箭头。
图片裁剪 | 支持 | 支持对图片进行普通裁剪。但是，不支持裁剪具有形状的图片。
图片重新着色 | 部分支持 | 某种图片重新着色（如黑白图片）在 ODF 中具有同等效果。其他图片重新着色的效果不同，会失去光泽。图片显示相同，但无法再更改或移除重新着色。
3D 图片选项 | 不支持 |
图片样式 | 部分支持 | 部分支持边框，但外观可能会有所不同。
主题 | 不支持 |
形状上的超链接 | 不支持 |


Office 自定义工具：配置快捷方式

配置快捷方式

修改或删除安装的 Office 应用程序的默认快捷方式，以及添加指向随 Office 2013 版本安装的或已经位于用户计算机上的任何文件的快捷方式。

若要添加新的快捷方式，请单击"添加"。若要修改列表中的快捷方式，请选择它，然后单击"修改"。若要从列表中删除快捷方式，请选择它，然后单击"删除"。

注意：

如果添加指向自定义应用程序或文件的快捷方式，则当用户修改、修复、重新安装或删除 Office 时，将不会更新或删除该快捷方式。


Office 自定义工具：OpenDocument 文本 (.odt) 格式和 Word (.docx) 格式之间的区别

OpenDocument 文本 (.odt) 格式和 Word (.docx) 格式之间的区别

以 OpenDocument 文本 (.odt) 格式保存 Microsoft Word 2013 中的文件，然后在 Word 中重新打开该文件时，您可能会注意到 Word 2013 版本和 OpenDocument 版本之间的一些格式设置差异。同样，当您在 Word 2013 中打开 OpenDocument 文件时，您可能也会看到格式设置差异。这是因为这两种文件格式支持的功能是不同的。

注意：

使用这两种文件格式时您将遇到的差异通常限制为格式设置差异和功能可用性。数据和内容将转换，但在这两种格式之间，您对数据和内容进行格式设置并与之交互的方式可能会有所不同。

如果要在 ODF 或 OpenXML（或其他格式）之间切换默认文件格式，请执行以下操作：

  1. 单击"文件"选项卡。

  2. 在"帮助"下，单击"选项"。

  3. 单击"保存"，然后在"保存文档"下的"将文件保存为此格式"列表中，单击要在默认情况下使用的文件格式。

我以 OpenDocument 文本格式保存 Word 2013 文档时，会发生什么情况？

下表显示 OpenDocument (.odt) 格式中完全支持、部分支持或不支持哪些 Word 2013 功能：

  • 支持 Word 2013 和 OpenDocument 文本格式都支持此功能。不会丢失内容、格式设置和可用性。

  • 部分支持 Word 2013 和 OpenDocument 文本格式都支持此功能，但格式设置和可用性可能会受到影响。不会丢失文本或数据，但格式设置及您使用文本或图形的方式可能会有所不同。

  • 不支持 Word 2013 中的功能在 OpenDocument 文本格式中不受支持。如果您计划以 OpenDocument 文本格式保存 Word 2013 文档，请不要使用此功能，否则您可能会丢失该部分文档的内容、格式设置和可用性。

有关 OpenDocument 格式中完全支持、部分支持或不支持的 Office 2013 图形功能的信息，请参阅本文末尾的"图形元素"表。

区域 子区域 支持级别 注释

协作

通讯簿

支持

协作

博客

支持

协作

注释

部分支持

以 .odt 格式保存文档并在 Word 2013 中重新打开该文档时，有关一组词的注释会变为单点。通常在一组词的末尾指示单点。

注释中不支持表。表的内容保留在注释中，但会丢失结构。

协作

比较-合并文档

支持

协作

文档保护

不支持

以 .odt 格式保存 Word 2013 文件时，会移除该功能，并且无法打开具有该功能的 .odt 文件。

协作

信息权限管理 (IRM)

不支持

以 .odt 格式保存 Word 2013 文档时，会移除该功能，并且无法打开具有该功能的 .odt 文件。

协作

邮件合并

支持

"地址块"和"收件人"字段会转换为纯文本。

如果其他 ODF 应用程序编辑该文档，则必须重新建立与数据源的连接。

协作

审阅窗格

支持

协作

跟踪更改

不支持

以 .odt 格式保存 Word 2013 文档时，会接受所有更改。

内容

书目

不支持

书目部分会转换为纯文本。

内容

题注

不支持

SEQ 字段会转换为纯文本。

添加新题注时，题注编号会自动增加。

内容

内容控件

不支持

内容

交叉引用

支持

内容

构建基块

不支持

内容

公式编辑器

支持

内容

公式

支持

内容

脚注-尾注

支持

不支持自定义分隔符。

内容

图文框

部分支持

以 .odt 格式保存 Word 2013 文档时：

  • 图文框会转换为文本框。

  • 不支持边距中的一些区域的定位标记。

  • 不支持的内容会导致图文框（而不是内容）丢失。不支持的内容包括：表、自选图形、文本框、图文框和 SmartArt 图形。

内容

框架集

不支持

内容

页眉-页脚

支持

内容

索引

支持

当前不支持多个列索引。

内容

插入分隔符

部分支持

以 .odt 格式保存 Word 2013 文档时，连续节分隔符可能会丢失一些属性，如上/下边距、页眉/页脚、边框和行编号。

内容

艺术字

支持

有关详细信息，请参阅"图形元素"表。

内容

页编号

支持

内容

图片

支持

不显示在 OpenOffice 中创建的文档中的图片。

内容

表

部分支持

不支持其列数超过 64 的表。

主题格式设置将转换为单元格级格式设置。

内容

模板和向导

支持

内容

文本框

部分支持

无法嵌套文本框。

内容

目录 (TOC)

部分支持

TOC 会丢失使用 SEQ 字段标记的项。

内容

机构目录 (TOA)

不支持

内容

图表目录 (TOF)

不支持

内容

E2O

支持

有关详细信息，请参阅"图形元素"表。

编辑

自动完成

支持

编辑

自动更正

支持

编辑

自动摘要

不支持

编辑

自动图文集

支持

自动图文集项存储在 Word 2013 模板 (.dotx) 中。如果以 .odt 格式保存包含自动图文集项的 Word 2013 模板，则自动图文集项不会保存在 .odt 版本中。

编辑

更改大小写

支持

编辑

单击和键入

支持

编辑

剪切-复制-粘贴

支持

编辑

信封和标签

支持

编辑

选择

支持

编辑

排序

支持

编辑

撤消-重做-重复

支持

编辑

字数统计

支持

文件操作

二进制文件格式

支持

可保存为二进制 .doc 和 .dot 文件类型。

文件操作

项目符号校验程序

支持

文件操作

加密

不支持

文件操作

固定文件格式

支持

可保存为 .pdt 和 .xps 文件类型。

文件操作

HTML 文件格式

支持

可保存为 .html 文件类型。

文件操作

主控文档

不支持

文件操作

Open XML 文件格式

支持

可保存为 .docx 和 .dotm 文件类型。

文件操作

组织者

支持

文件操作

RTF 文件格式

支持

可保存为 .rtf 文件类型。

文件操作

文本转换器

支持

文件操作

文本编码

支持

文件操作

信任中心

支持

文件操作

Word 2013 转换器

支持

文件操作

WordML 文件格式

支持

可保存为 WordML 文件类型。

文件操作

WSS 集成

支持

格式设置

自动格式化

格式设置

背景

不支持

格式设置

边框和底纹

支持

不支持底纹上的模式

不支持图片边框样式。它们会转换为实线。

格式设置

项目符号和编号

支持

编号/项目符号和文本之间的间距可能会稍有不同。

增加了列表项之间的间距，以便匹配文档的行距。

在 Word 2013 中打开 .odt 文件时，OpenOffice 中的默认项目符号会更改外观。

格式设置

首字下沉

支持

不支持边距的某些区域的定位标记。

格式设置

格式一致性检查

支持

格式设置

格式刷

支持

格式设置

荧光笔

支持

以 .odt 格式保存文档时，突出显示会转换为字符背景色。

格式设置

水平线

支持

格式设置

段落

支持

格式设置

展现格式

支持

格式设置

样式

支持

以 .odt 格式保存文档后，样式数会增加，并且 ODF 中的所有格式设置都是基于样式的。

格式设置

制表符

支持

不支持位置制表符。

格式设置

文本列

支持

与部分关联的一些属性可能会丢失，如上/下边距、页眉/页脚、边框或行编号。

格式设置

文本方向

部分支持

支持以下文本方向格式：

  • rltb：从右到左，从上到下

  • lrtb：从左到右，从上到下

  • tbrl：从上到下；从右到左

不支持表格单元格中的文本方向。

格式设置

主题

不支持

格式设置

水印

不支持

格式设置

实时预览

支持

格式设置

定位

部分支持

一些文本框、图文框和形状的位置可能会发生更改，具体取决于使用的定位标记的类型。

基础结构

Acetate

支持

以 .odt 格式保存时，包含内容控件的内容会转换为常规文字。

基础结构

书签

支持

基础结构

启动-退出

支持

基础结构

Cicero - 手写 - 语音

支持

基础结构

数据绑定

不支持

基础结构

DDE

不支持

字段的内容会转换为纯文本。

会丢失指向数据源的链接。

基础结构

字段

部分支持

不支持的字段会转换为纯文本。

支持的字段继续保留为字段。

不支持 SEQ 字段，它们会影响 TOC 和题注的行为。

基础结构

ActiveX/表单

不支持

基础结构

冷冻干燥

支持

基础结构

帮助

支持

基础结构

超链接

支持

OpenOffice 中的文档未应用超链接样式，但仍有效。

基础结构

墨迹批注

不支持

基础结构

键盘自定义

不支持

基础结构

OCX

不支持

基础结构

OLE

部分支持

不显示在 OpenOffice 中创建文档中嵌入的对象。不支持该图像类型，并且链接是相对的。

国际

IME

支持

国际

插入符号

支持

国际

可插式 UI

支持

国际

双行合一

支持

MODI

OCR

支持

导航

文档结构图

支持

导航

查找-替换

支持

导航

转到 - 返回

支持

打印

支持

打印

页面设置

支持

打印

打印预览

支持

可编程性

加载项

部分支持

可编程性

C-API

部分支持

可编程性

COM 加载项

部分支持

可编程性

事件

部分支持

可编程性

宏

不支持

可编程性

对象模型

支持

可编程性

智能文档

不支持

可编程性

智能标记

不支持

可编程性

VBA 录制

支持

可编程性

VBE 集成

支持

可编程性

WordBasic

支持

校对

自定义词典

支持

校对

语法

支持

标记为"不检查拼写或语法"的文本区域将丢失该属性。现在将对该文本检查拼写和语法。

校对

断字

支持

校对

智能自动更正

支持

校对

语言自动检测

支持

校对

语言属性

支持

校对

拼写

支持

标记为"不检查拼写或语法"的文本区域将丢失该属性。现在将对该文本检查拼写和语法。

校对

同义词库

支持

校对

翻译

支持

研究

研究窗格

支持

视图

草稿

支持

视图

大纲

支持

视图

页面视图

支持

视图

阅读

支持

视图

标尺

支持

视图

滚动

支持

视图

状态栏

支持

视图

缩略图

支持

视图

Web 版式

支持

视图

窗口化

支持

视图

缩放

不支持

WordMail

自动签名

支持

WordMail

传真

支持

WordMail

HTML

支持

WordMail

选项

不支持

WordMail

纯文本

支持

WordMail

RFM

支持

WordMail

RTF

支持

XML

附加架构

不支持

XML

属性

不支持

XML

外部源

不支持

XML

包含文本

不支持

XML

合并 XML

不支持

XML

OOUI

不支持

XML

选择行为

不支持

XML

树视图

不支持

XML

验证

不支持

XML

XSLT

不支持

图形功能

下表显示 OpenDocument 格式 (.odt) 中完全支持、部分支持或不支持哪些 Word 2013 图形功能：

  • 支持 Word 2013 格式和 OpenDocument 格式都支持此功能。使用此功能的图形通常在任一格式下具有相同的外观和行为。

  • 部分支持 Word 2013 格式和 OpenDocument 格式都支持此功能，但这两种格式的图形的外观可能会有所不同。通常不会丢失这两种格式之间的数据，但格式设置和您处理这些图形的方式可能会有所不同。

  • 不支持 由于 Word 2013 格式和 OpenDocument 格式之间的功能和实现的独特差异，此功能在 OpenDocument 格式下不受支持。如果您计划以 OpenDocument 格式保存文档，请不要在 Word 2013 中使用这些功能。

基本形状 | 支持级别 | 注释
形状 | 支持 |
文本框 | 支持 | 支持，但 Word 2013 部分支持的文本框中的对象除外。文本框内的 SmartArt 图形、形状或文本框不受支持，当您打开文件时，它们会丢失。
艺术字 | 支持 |
3D 形状选项 | 支持 |
图片 | 支持 | 支持，但 ODF 不支持的插入和链接选项除外。
SmartArt 图 | 支持 | 转换为一组形状。
ActiveX 控件 | 不支持 |
图表中的对象 | 支持 | 转换为包含图表和对象的组。Word 2013 无法支持包含图表的组，所以在 Word 2013 中打开该文件时，将对这些对象取消分组。
签名行对象 | 不支持 |
墨迹注释 | 支持 | 墨迹注释将转换为增强型图元文件 (EMF) 图像。
对象的分组 | 部分支持 | 一些对象无法在 Word 2013 中分组在一起，因此在打开 OpenDocument 文件时，会取消分组这些对象。这些对象包括使用图表分组的任何对象，以及使用形状、文本框或 OLE 对象分组的图片。
对象可见性 | 部分支持 | 以 .odt 保存文件，然后在 Word 2013 中重新打开时，不可见的对象会变为可见。
对象边框 | 支持 | 并非支持所有边框样式。不支持的边框样式会保存为默认边框样式（黑色，实线）。
对象填充 | 支持 | 支持，但停止点数多于 2 的渐变填充会丢失前两个停止点后的所有停止点。
行格式设置 | 支持 | 并非所有行和行行尾样式都在 ODF 中受支持。不支持的样式会分别保存为默认的黑色实线和开放型箭头。
图片裁剪 | 支持 | 支持对图片进行普通裁剪。但不支持裁剪包含形状的图片。
图片重新着色 | 部分支持 | 某种图片重新着色（如黑白图片）在 ODF 中具有同等效果。其他图片重新着色的效果不同，会失去光泽。图片显示相同，但无法再更改或移除重新着色。
3D 图片选项 | 不支持 |
图片样式 | 部分支持 | 部分支持边框，但外观可能会有所不同。
主题 | 不支持 |
形状上的超链接 | 不支持 |


Office 自定义工具："修改组"对话框

"修改组"对话框

修改组时，可以在"修改组"对话框中选择以下任一或所有选项，然后单击"确定"。

在"选择此发送/接收组的选项"下，选择以下选项：

  • 发送邮件项目 - 在对此组执行发送/接收时发送发件箱中的邮件项目。

  • 接收邮件项目 - 在对此组执行发送/接收时接收邮件项目。

  • 文件夹主页脱机时可用 - 在对此组执行发送/接收时刷新文件夹主页中的内容。

  • 同步处理窗体 - 在对此组执行发送/接收时同步处理窗体。

在"更改此发送/接收组的文件夹选项"下，选择文件夹，然后提供以下信息：

  • 在"发送/接收"中包含此文件夹 - 在此发送/接收组的发送/接收期间将此文件夹添加到要更新的文件夹组中。

对于有些文件夹，以下选项同样适用：

  • 仅下载邮件头 - 在通过执行此发送/接收组的发送/接收进行更新时仅下载此文件夹的邮件头。

  • 下载包含附件在内的整个项目 - 在通过执行此发送/接收组的发送/接收进行更新时下载此文件夹的整个电子邮件（或其他项目）。

  • 如果项目超过以下大小，则仅下载邮件头 - 当项目大于指定大小时，仅下载此项目的邮件头。通过执行此发送/接收组的发送/接收进行更新时，此设置仅适用于此文件夹。


Office 自定义工具：Exchange 设置

Exchange 设置

单击"Exchange 设置"对话框中的"其他设置"按钮可配置 Outlook 无处不在功能。

使用以下选项配置用户的 Outlook 配置文件以使用脱机使用和 Outlook 无处不在功能：

  • 配置 Outlook 无处不在

  • 使用 HTTP 连接到 Exchange 邮箱 - 选择此选项以启用 Outlook 无处不在。

如果已启用 Outlook 无处不在，则可配置以下选项：

  • 使用此 URL 连接到 Exchange 的代理服务器 - Outlook 无处不在代理服务器的服务器名称 URL。请勿输入 http:// 或 https:// 作为名称的一部分。相应的输入（http:// 或 https://）将在您输入名称后根据所选的身份验证设置自动包括在框中。

  • 仅使用 SSL 连接 - 选择此选项以便仅使用安全套接字层进行连接。如果既要支持服务器身份验证又要支持客户端身份验证，请选择：

    • 使用 SSL 连接时相互验证会话 - 如果已启用此选项，请输入"代理服务器的主体名称"。

  • 在快速网络中，先使用 HTTP 连接，再使用 TCP/IP 连接 - 在快速网络中，先使用 Outlook 无处不在 (HTTP) 而不是默认的 LAN (TCP/IP) 进行连接。

  • 在低速网络中，先使用 HTTP 连接，再使用 TCP/IP 连接 - 在低速网络中，先使用 Outlook 无处不在 (HTTP) 而不是默认的 LAN (TCP/IP) 进行连接。

  • 连接到 Exchange 的代理服务器时使用此身份验证 - 默认的方法为密码身份验证 (NTLM)。


Office 自定义工具：Outlook 配置文件

Outlook 配置文件

自定义用户的默认 Outlook 配置文件，它们是 Windows 注册表中定义用户特定信息的多组值。

配置新 Exchange Server 连接的设置，或替换现有 Exchange Server 连接中的设置。必须将配置信息键入以下字段：

一个 Outlook 2013 配置文件可包含多个电子邮件帐户。用户可具有多个 Outlook 2013 配置文件，但您只能在安装程序自定义文件中配置一个配置文件。

  • 使用现有配置文件 - 使用用户计算机上已经配置的配置文件，或者在首次启动 Outlook 2013 时提示用户创建配置文件。选择此选项会禁用 OCT 的其他 Outlook 2013 部分。

  • 修改配置文件 - 修改用户计算机上的默认配置文件，或定义对具有您指定的名称的配置文件所做的更改。如果不存在默认配置文件，或者不存在您指定的名称的配置文件，则 Outlook 2013 会根据您在 OCT 的其他 Outlook 2013 部分中选择的选项创建配置文件。Outlook 2013 使用默认配置文件名称 Outlook 或您指定的配置文件名称。

  • 新建配置文件 - 在用户计算机上创建新配置文件，并使其成为默认配置文件；不会删除任何现有配置文件，用户仍然可以使用它们。您必须在"配置文件名称"框中键入名称。此名称显示在 Outlook 2013 的"电子邮件帐户"对话框中。Outlook 2013 会根据您在 OCT 的其他 Outlook 2013 部分中选择的选项创建配置文件。

  • 应用 PRF - 导入 Outlook 配置文件（PRF 文件）以定义新的默认配置文件或更新现有配置文件。选择此选项会禁用 OCT 中的其他 Outlook 2013 部分，但不会使用 PRF 文件中的设置更新 OCT。在"应用以下配置文件(PRF 文件)"框中，键入该配置文件的名称和路径。如果为以前版本的 Outlook 2013 创建了 PRF 文件，则当该配置文件只定义了 MAPI 服务时，可将其导入 Outlook 2013。

如果在用户没有管理权限的锁定的计算机上安装 Office，用户将无法在安装 Office 后配置其 Outlook 2013 配置文件。


Office 自定义工具："删除/修改注册表项"对话框

"删除/修改注册表项"对话框

在"删除注册表项"或"修改注册表项"对话框中，为每个注册表项键入以下信息，然后单击"确定"：

  1. 展开"根"菜单，然后选择包含要删除或修改的项的分支。

  2. 在"项"框中，键入存储该项的子项的名称；例如 Software\Microsoft\Office\15.0\Common。

  3. 对于"值名称"，键入要删除的注册表项的名称。若要删除整个子项（包括所有值项），请将此字段留空。


Office 自定义工具："添加/修改注册表"对话框

"添加/修改注册表项"对话框

在"添加注册表项"或"修改注册表项"对话框中，可为每个注册表项配置以下信息，然后单击"确定"：

  • 展开"根"菜单，并选择包含要添加或修改的项的分支。设置对每个用户应用一次 (HKEY_CURRENT_USER) 或对每台计算机应用一次 (HKEY_LOCAL_MACHINE)。注意，不能向 HKEY_USERS 或 HKEY_LOCAL_MACHINE 的根位置添加注册表项。展开"数据类型"菜单并选择您要添加或修改的注册表值的数据类型。在"项"框中，键入存储该项的子项的名称，例如 Software\Microsoft\Office\15.0\Common。

  • 如果注册表项不包含值名称或值数据，请选择"创建空项"。有些设置由是否存在注册表项确定。在"值名称"中，键入新注册表项的名称。如果包括"值数据"，但将此字段留空，则会为该值分配名称 <Default>。一个项只能有一个 <Default> 值名称。在"值数据"框中，键入要在新注册表项中存储的值。该数据必须与数据类型相符。


Office 自定义工具：导出设置

导出设置

将现有 Outlook 配置文件设置保存到 PRF 文件。

单击"导出配置文件设置"。在"另存为"对话框中，键入新 PRF 文件的名称，然后单击"保存"。

注意：

创建 Outlook PRF 文件的有效方式是使用 OCT 进行选择，然后将它们导出到 PRF 文件 - 即使您在部署 Office 时未使用安装程序自定义文件。您可编辑 PRF 文件以进行不在 OCT 中公开的其他自定义设置。例如，可添加 OCT 中未列出的电子邮件提供程序。


Office 自定义工具：添加帐户

添加帐户

在用户的配置文件中包含新的 Outlook 电子邮件帐户。

如果不希望向您要配置的 Outlook 配置文件添加帐户，请选择"不自定义 Outlook 配置文件和帐户信息"。

若要向列表添加新帐户，请单击"添加"。若要修改列表中的帐户，请选择它，然后单击"修改"。若要从列表中删除帐户，请选择它，然后单击"删除"。

还可以指定以下内容：

  • 配置 Exchange Server 或添加 Outlook 数据文件（.pst 文件）时，请展开"将新邮件传递到以下位置"，然后选择新电子邮件的传递位置。默认位置为 Exchange Server，如果已配置；否则，位置将默认为用户计算机上的 .pst 文件。

  • 展开"默认电子邮件帐户"，然后选择将成为用户默认电子邮件帐户的帐户。


Office 自定义工具："文件目标路径"对话框

"文件目标路径"对话框

在"用户计算机上的目标路径"对话框中，键入要在用户计算机上安装该文件的文件夹的路径，然后单击"确定"。

可以使用 Shift 和 Ctrl 键一次选择多个文件；这些文件与同一目标文件夹关联。可以在目标路径中使用以下特殊的文件夹名称：

[INSTALLLOCATION] | 安装 Office 的文件夹
[ROOTDRIVE] | 具有最大可用空间的本地磁盘驱动器
[ProgramFilesFolder] | Program Files 文件夹
[CommonFilesFolder] | Program Files\Common Files 文件夹
[WindowsFolder] | Windows 文件夹
[SystemFolder] | Windows System32 文件夹
[PersonalFolder] | 用户的"我的文档"文件夹
[AppDataFolder] | 用户的 Application Data 文件夹
[NetHoodFolder] | 用户的"网上邻居"文件夹


Office 自定义工具："添加/修改快捷方式项"对话框

"添加/修改快捷方式项"对话框

在"添加/修改快捷方式项"对话框中，为您要创建或修改的快捷方式键入以下信息，然后单击"确定"：

  • 目标 - 通过选择预定义的应用程序关键字或者通过键入快捷方式将指向的文件的名称和路径来指定与快捷方式关联的应用程序。如果选择应用程序关键字，OCT 将自动在其余框中输入信息。列表中的名称对应于您在 OCT 的"设置功能安装状态"页上所选的功能，以及添加到"添加文件"页上的安装中的任何自定义文件。如果键入名称和路径，且名称或路径包含空格，则必须用双引号 ("") 将整个字符串引起来。可以使用"参数"字段为应用程序添加命令行选项。

  • 位置 - 通过选择预定义的文件夹关键字或键入快捷方式位置的名称和路径来指定在其中创建快捷方式的文件夹。可以通过在子文件夹名称后面附加一个反斜杠 (\) 来指定子文件夹。例如，若要在"开始"菜单的"程序"文件夹的 Office 子文件夹下安装 Word 快捷方式，请选择 [ProgramMenuFolder] 并按如下所示附加子文件夹名称：[ProgramMenuFolder]\Microsoft Office。可以对"位置"使用以下特殊文件夹：

    [StartMenuFolder]

    Windows"开始"菜单

    [ProgramMenuFolder]

    Windows"开始"\"程序"菜单

    [StartupFolder]

    Windows"开始"\"程序"菜单中的启动文件夹

    [DesktopFolder]

    Windows 桌面文件夹

    [INSTALLLOCATION]

    其中安装有 Office 的文件夹

    [FavoritesFolder]

    用户的收藏夹文件夹

    [FavoritesFolder]

    用户的收藏夹文件夹

    [AppDataFolder]

    用户的 Application Data 文件夹

    [NetHoodFolder]

    用户的网上邻居文件夹

  • 名称 - 通过键入任意字符串来指定快捷方式的名称。

  • 起始位置 - 通过键入路径来指定应用程序的默认起始文件夹。如果保留此框为空，则默认文件夹将设置为目标文件所在的文件夹。如果路径在用户计算机上无效，则用户在尝试使用快捷方式时将看到错误消息。

  • 参数 - 在命令行上键入要传递到应用程序的可选参数。

  • 快捷键 - 键入应用程序或文件的可选键盘快捷方式。快捷键的语法为：[modifier+]VK_key，其中修饰符为 SHIFT、CTRL、ALT 或 EXT，而 VK_key 是一个虚拟键名称（参见下表）。

    修饰符是可选的，可以按任意顺序指定多个修饰符，用加号 (+) 分隔。如果使用修饰符，则它必须先于虚拟键名称。必须输入一个虚拟键名称。请勿在键定义中使用空格。下面是一些示例：

    • CTRL+VK_F12

    • CTRL+SHIFT+VK_A

    • ALT+CTRL+VK_SNAPSHOT

    系统可能使用一些组合键（如 CTRL+ALT+VK_DELETE），这些组合键可能无法按预期启动应用程序。请注意在用户计算机上避免冲突，尤其在未使用修饰符指定快捷键的情况下。例如，如果未使用修饰符指定 VK_A，则每次用户键入 A 键时都会运行应用程序。

    可以使用以下虚拟键名称：

    虚拟键名称 十六进制键代码 描述

    VK_0 … VK_9

    30-39

    键 0-9

    VK_A … VK_Z

    41-5A

    键 A-Z

    VK_NUMPAD0 … VK_NUMPAD9

    60-69

    数字键盘上的键 0-9

    VK_F1 ... VK_F24

    70-87

    功能键 F1-F24

    VK_LBUTTON

    1

    鼠标左键

    VK_RBUTTON

    2

    鼠标右键

    VK_CANCEL

    3

    控制中断处理

    VK_MBUTTON

    4

    鼠标中键（三键鼠标）

    VK_BACK

    8

    Backspace 键

    VK_CLEAR

    0C

    清除键

    VK_RETURN

    0D

    Enter 键

    VK_PAUSE

    13

    Pause 键

    VK_CAPITAL

    14

    Caps Lock 键

    VK_PRIOR

    21

    Page Up 键

    VK_NEXT

    22

    Page Down 键

    VK_END

    23

    End 键

    VK_HOME

    24

    Home 键

    VK_LEFT

    25

    向左键

    VK_UP

    26

    向上键

    VK_RIGHT

    27

    向右键

    VK_DOWN

    28

    向下键

    VK_SELECT

    29

    选择键

    VK_EXECUTE

    2B

    执行键

    VK_SNAPSHOT

    2C

    Print Screen 键

    VK_INSERT

    2D

    Ins 键

    VK_HELP

    2F

    帮助键

    VK_MULTIPLY

    6A

    乘号键

    VK_ADD

    6B

    加号键

    VK_SEPARATOR

    6C

    分隔符键

    VK_SUBTRACT

    6D

    减号键

    VK_DECIMAL

    6E

    小数键

    VK_DIVIDE

    6F

    正斜杠键

    VK_NUMLOCK

    90

    Num Lock 键

    VK_SCROLL

    91

    Scroll Lock 键

  • 运行 - 选择要在其中启动应用程序或文件的窗口的类型（"普通窗口"、"最小化"或"最大化"）。

  • 更改图标 - 选择不同的快捷方式图标。


Office 自定义工具："添加/修改属性值"对话框

"添加/修改属性值"对话框

在"修改安装程序属性"对话框中，如果单击"添加"，则会打开"添加属性值"对话框。如果在"修改安装程序属性"对话框中选择某项，然后单击"修改"，则会打开"修改属性值"对话框。您可以在"添加属性值"或"修改属性值"对话框中输入以下信息：

  1. 在"添加属性值"或"修改属性值"对话框的"名称"框中，键入属性名称。属性名称必须大写。

  2. 在"值"框中，键入属性值。

  3. 单击"确定"。


Office 自定义工具：授权和用户界面

授权和用户界面

代表使用此安装程序自定义文件安装 Office 的每位用户输入产品密钥并接受最终用户许可协议 (EULA)；同时设置用户界面显示级别。仅当在用户计算机上首次安装 Office 时，安装程序才会识别这些选项。

  1. 选择下列两个选项之一：

    • 使用 KMS 客户端密钥 - 使用密钥管理服务 (KMS) 激活的企业部署不需要输入产品密钥，这是因为 Office 2013 的所有批量许可版本都预安装了 KMS 客户端密钥。KMS 是 Office 激活技术提供的方法之一，用于激活依照 Microsoft 批量许可计划授权的产品。只有 KMS 主计算机需要激活 KMS 主机密钥，以及在环境中建立本地激活服务。Office 2013 连接到本地 KMS 主机以执行激活。默认情况下，"使用 KMS 客户端密钥"选项处于选中状态。有关 Office 2013 的许可选项的详细信息，请参阅当前版本中包含的"Office 激活技术指南"。

    • 输入另一个产品密钥 - 您可以使用"输入另一个产品密钥"项在 OCT 中输入有效的多次激活密钥 (MAK) 密钥。MAK 密钥是 Office 激活技术提供的另一种方法，用于激活依照 Microsoft 批量许可计划授权的产品。利用 MAK，客户可以使用 Microsoft 托管的激活服务器以联机方式激活 Office 2013 或通过电话激活。若要使用 MAK 密钥，请在"输入另一个产品密钥"文本框中，输入不带空格的 MAK 密钥（25 个数字或字符）。

  2. 在"产品密钥"框中，键入一个 25 个字符的有效批量许可证密钥。

  3. 选择"我接受《许可协议》中的条款"代表用户接受许可协议的条款。在安装过程中或首次运行 Office 应用程序时都不会提示用户接受许可协议。

  4. 展开"显示级别"菜单以便在安装过程中设置用户界面行为。选择下列选项之一：

    • 选择"完全 - 默认"以便以交互方式运行安装，并显示所有用户界面和消息。

    • 选择"基本"可显示欢迎屏幕以及产品密钥和 Microsoft 软件许可条款的提示，如果需要，还可显示进度栏和完成通知。

    • 选择"无"可以静默方式运行安装程序，而不显示任何用户界面。

      注意：

      如果"显示级别"设置为"基本"或者"无"且您提供了产品密钥，则安装程序假定您也代表用户接受许可协议，即使您没有选中此复选框也是如此。

  5. 如果希望安装程序在安装完成后向用户显示消息，请选择"完成通知"。

  6. 如果不希望安装程序显示错误消息或可能中断安装的其他对话框，请选择"抑制模式"。

    注意：

    如果"显示级别"设置为"完全 - 默认"，则无论此复选框处于哪种状态，均将显示错误消息和其他对话框。

    注意 前面的选项与 Config.xml 文件中的以下设置相同：

    OCT 选项 Config.xml 设置

    产品密钥

    PIDKEY 元素

    我接受《许可协议》中的条款

    Display 元素的 AcceptEula 属性

    显示级别

    Display 元素的 Level 属性

    完成通知

    Display 元素的 CompletionNotice 属性

    抑制模式

    Display 元素的 SuppressModal 属性


Office 自定义工具：删除文件

删除文件

安装 Office 后从用户计算机中删除文件。

在安装"添加文件"列表中列出的文件之前，"删除文件"列表中列出的文件将从用户的计算机中删除。因此，可以删除用户计算机上现有的文件并将其替换为新版本。如果用户计算机上的目标文件已重命名或已修改，则具有同一名称的已添加文件不会替换它。

若要创建要在安装期间从用户计算机中删除的文件列表，请单击"添加"。若要修改文件的路径或名称，请在"删除文件"列表中选择文件，然后单击"修改"。若要从列表中删除文件，请选择该文件，然后单击"删除"。可以使用 Shift 和 Ctrl 键一次选择多个文件。


Office 自定义工具：添加文件

添加文件

安装 Office 后将文件添加到用户计算机。

  • 若要创建要在安装期间添加到用户计算机的文件列表，请单击"添加"，导航到要添加到列表的文件，然后再次单击"添加"。可以使用 Shift 和 Ctrl 键一次选择多个文件。

    在"文件目标路径"对话框中，"文件名"框将使用所选文件的名称自动填充。在"用户计算机上的目标路径"框中，键入要为用户计算机上的目标文件夹使用的路径，或者保留建议的路径，然后单击"确定"。

  • 若要更改文件的目标路径，请在列表中选择该文件，然后单击"修改"。

  • 若要从列表中删除文件，请选择该文件，然后单击"删除"。可以使用 Shift 和 Ctrl 键一次选择多个文件。

为 Office 安装添加文件时，请注意以下内容：

  • 保存自定义文件并退出 OCT 时，文件将复制到安装程序自定义文件。大型文件会增加自定义文件的大小和创建它所需的时间。

  • 如果更改当前包含在自定义文件中的某个文件，则必须在 OCT 中打开自定义文件，从"添加文件"列表中删除该文件，添加修改后的版本，然后保存自定义文件。

  • 如果用户删除、修复或重新安装 Office，则自定义文件将随 Office 一起删除或重新安装。但是，如果安装之后自定义文件发生了更改，则安装程序不会重新安装该文件。


Office 自定义工具：修改用户设置

修改用户设置

为使用此自定义文件安装 Office 的用户设置 Office 应用程序设置的默认值。

  1. 若要配置应用程序的设置，请在左窗格中，展开应用程序文件夹和子文件夹，直到要配置的设置在详细信息窗格中列出。

    可以单击"显示所有设置"显示所有可用的应用程序设置，或者单击"仅显示已配置的设置"以便仅显示之前已配置且保存到此配置文件的那些设置。

  2. 单击设置可在对话框底部显示说明如何配置该设置的信息。

  3. 若要配置设置，请双击要配置的设置，然后选择"未配置"、"已启用"或"已禁用"。其中每个选项均会对设置产生不同影响，且选中设置时对话框底部显示的信息将对每个选项进行说明。

    未配置

    保持原有设置。

    已启用

    根据您在对话框中所选的选项修改设置。

    已禁用

    已禁用设置。禁用某个选项可能与不配置该选项有所不同。有关更多详细信息，请参阅特定选项的说明。

  4. 在此对话框中，可通过单击"上一设置"或"下一设置"浏览设置列表。

  5. 单击"确定"。

  6. 选择"迁移用户设置"可保留早期版本 Office 中的用户自定义设置。如果修改用户设置并选中此复选框，则安装程序首先会应用修改后的设置，然后迁移用户现有的自定义设置，并覆盖任何冲突的设置。

注意：

如果单击"已启用"查看设置的选项，然后单击"确定"、"上一设置"或"下一设置"，则状态将更改为"已配置"，即使您没有更改该设置也是如此。如果配置的设置中无意中包含了空超链接、路径或文件名，则会导致错误。如果单击了"已启用"并希望忽略所做的更改或者避免配置设置，请单击"取消"。还可以通过以下方法使设置返回到"未配置"状态：双击该设置，选择"未配置"并单击"确定"。


Office 自定义工具：概述

可使用 Office 自定义工具 (OCT) 来自定义 Office 2013 的安装。运行 OCT 时，可以选择是要创建一个新的安装程序自定义文件还是打开现有的文件。如果要创建一个新文件，OCT 会显示网络安装点上提供的产品列表。必须选择一个要自定义的产品。若要启动 OCT，请在命令行中键入 setup.exe /admin。

注意：

Office 2013 OCT 要求在所有运行 Office 的计算机（包括用于运行 OCT 的计算机）上使用 Windows Installer 4.0 或更高版本。

安装程序自定义文件

使用 OCT，可以自定义 Office 并将自定义项保存在安装程序自定义文件（.msp 文件）中，然后将该文件放置在网络安装点上的 Updates 文件夹中。在安装 Office 时，安装程序会在 Updates 文件夹中查找安装程序自定义文件，如果找到，将应用这些自定义项。如果将自定义文件放置在 Updates 文件夹之外的某个位置，则可以使用安装程序命令行选项/adminfile 指定该文件的完全限定路径；例如，setup.exe /adminfile \\server_name\share_name\subfolder\custom.msp。

有关安装程序命令行选项的信息，请参阅 Office 2013 资源工具包中的"Office 2013 的安装程序命令行选项"。

注意：

如果为自定义文件使用 Updates 文件夹之外的文件夹，则可以使用 SetupUpdates 元素的 SUpdateLocation 属性在 Config.xml 文件中指定其位置。有关详细信息，请参阅 Office 2013 资源工具包中的"Office 2013 中的 Config.xml 文件"。

还可以使用安装程序自定义文件更改现有安装。由于安装程序自定义文件是 Windows Installer .msp 文件的扩展形式，因此可将该自定义文件应用到用户计算机上（就像应用软件更新一样），且用户现有的 Office 安装会使用自定义项进行更新。例如，如果将某些功能的安装状态更改为"不可用"，然后将生成的自定义文件应用到 Office 的现有安装，则这些功能会从用户计算机中删除。

如果使用 OCT 修改现有 .msp 自定义文件，建议您为要自定义的同一产品选择 .msp 文件。例如，如果您要自定义现有的 Office Professional Plus 2013 安装，请选择 Office Professional Plus 2013 自定义 .msp 文件。

OCT 支持按如下所示导入安装程序自定义更新：

  • 可将 32 位安装程序自定义更新导入 64 位 OCT 中，然后，可以使用这些更新自定义 64 位 Office 产品。

  • 可将 64 位安装程序自定义更新导入 32 位 OCT 中，然后，可以使用这些更新自定义 32 位 Office 产品。

导入到 64 位 OCT 中的 32 位安装程序自定义更新会转换为 64 位形式，而导入到 32 位 OCT 中的 64 位自定义更新会转换为 32 位形式。若要导入自定义更新（.msp 文件），请在 Office 自定义工具中选择"文件"菜单上的"导入"。在"打开"对话框中，选择要转换的 .msp 文件，然后单击"打开"启动转换。

注意：

导入自定义 .msp 文件仅适用于等效的跨体系结构产品。您可以将 32 位 Office Professional Plus 2013 自定义 .msp 文件导入 64 位 Office Professional Plus 2013 .msp 文件的 64 位版本的 OCT 中。但不能将 32 位 Word 2013 独立自定义 .msp 文件导入 64 位 Office Professional Plus 2013 .msp 文件的 64 位 OCT 中。这样做是不允许的，并会显示错误消息。有关如何使用 OCT 创建安装程序自定义文件以及有关可使用 OCT 配置的所有领域的信息，请参阅 Office 2013 资源工具包中的"Office 2013 中的 Office 自定义工具"。

不能将 2007 Office system 安装程序自定义更新导入 Office 2013 OCT 中。

如果已经为 Office 2013 产品（如 Office Professional Plus 2013）创建了初始安装程序自定义 .msp 文件，并且稍后要修改安装以为该产品添加语言包，则也可以使用"导入"功能。在这种情况下，首先要将语言包添加到包含 Office 产品源文件的网络安装点。然后，从网络安装点的根目录运行 OCT，为同一产品创建新的安装程序自定义文件，并导入以前为产品（本例中为 Office Professional Plus 2013）创建的原始自定义 .msp 文件。若要导入 .msp 文件，请在 OCT 中的"文件"菜单上单击"导入"。在"打开"对话框中，选择要更新的以前创建的自定义 .msp 文件。在"文件"菜单上，单击"另存为"。为 .msp 文件指定唯一名称，然后单击"保存"。将以前创建的自定义 .msp 文件导入 OCT 中会更新 .msp 文件并包括添加的语言。

有关如何导入 .msp 自定义文件的详细信息，请参阅 Office 2013 资源工具包中的"导入 Office 2013 安装程序自定义文件"。有关如何创建网络安装点的信息，请参阅 Office 2013 资源工具包中的"安装 Office 2013 之前自定义安装程序"中的"创建网络安装点"。

OCT 中有一些仅适用于新安装的 Office 的选项。这些选项可由 OCT 和 OCT 帮助文件识别。例如，可以使用 INSTALLLOCATION 元素指定在用户计算机上安装 Office 的文件夹位置。但如果自定义文件适用于现有安装，则将忽略 INSTALLLOCATION 元素。（您需要卸载并重新安装 Office 以更改安装位置。）

选择"文件"菜单上的"保存"以在退出 OCT 之前保存安装程序自定义文件。

配置 OCT

OCT 主要包含以下四个部分，每个部分分为多个页面，其中包含下列可自定义的选项：

  • 安装

    • 安装位置和单位名称

    • 其他网络资源

    • 授权和用户界面

    • 删除以前的安装

    • 添加安装并运行程序

    • Office 安全设置

    • 修改安装程序属性

  • 功能

    • 修改用户设置

    • 设置功能安装状态

  • 其他内容

    • 添加文件

    • 删除文件

    • 添加注册表项

    • 删除注册表项

    • 配置快捷方式

  • Outlook

    • Outlook 配置文件

    • 添加帐户

    • 导出设置

    • 指定发送/接收组


Office 自定义工具：删除之前的安装

删除以前的安装

指定要保留或删除的 Office 应用程序的早期版本。此选项仅适用于在用户计算机上首次安装 Office 的情况。

默认情况下，安装程序会删除 Office 应用程序的所有早期版本。若要保留已安装的 Office 应用程序，请完成下列步骤：

  1. 选择"删除下列早期版本的 Microsoft Office 程序"。

  2. 选择不希望删除的 Office 应用程序，然后单击"详细信息"。

  3. 在"选择希望安装程序删除的早期版本"下，清除复选框，然后单击"确定"。

注意：

Microsoft Outlook 2013 不能与早期版本的 Outlook 共存。如果选择保留早期版本，请不要安装 Outlook 2013。